could not build a module (jmvtools::install())

Everything related to the development of modules in jamovi

by dannyy » Mon Sep 30, 2019 6:04 pm

Hi

I am working on your tutorials. When I am trying to install 'SuperAwesome' module, I am getting an error like below. I updated the latest version of jamovi and jmvtools. How can I fix it?

> jmvtools::install()

jamovi compiler

jamovi found at C:\Program Files\jamovi 1.1.5.0\bin\jamovi.exe
wrote: ttest.h.R
wrote: ttest.u.yaml
wrote: ttest.src.js
wrote: ttest.js
writing module meta
wrote: 0000.yaml
wrote: jamovi.yaml
'C:\PROGRA~1\jamovi' is not recognized as an internal or external command,
operable program or batch file.

Could not build module
dannyy
 
Posts: 2
Joined: Mon Sep 30, 2019 5:57 pm

by jonathon » Mon Sep 30, 2019 11:57 pm

hi,

i'm surprised that it found jamovi at all, without you providing a `home` argument to `jmvtools::install()`.

did you provide a home argument?

kind regards

jonathon
User avatar
jonathon
 
Posts: 1059
Joined: Fri Jan 27, 2017 10:04 am

by dannyy » Mon Oct 07, 2019 3:19 pm

I was trying to handle this issue,but I could not. This is my code written by following your tutorial.

jmvtools::check(home="C:\\Program Files\\jamovi 1.0.7.0")
options(jamovi_home="C:\\Program Files\\jamovi 1.0.7.0")
jmvtools::create('SuperAwesome')
setwd('SuperAwesome')
jmvtools::addAnalysis(name='ttest', title='Independent Samples T-Test')
jmvtools::install(home="C:\\Program Files\\jamovi 1.0.7.0")
Output
> jmvtools::check(home="C:\\Program Files\\jamovi 1.0.7.0")

jamovi compiler

jamovi found at C:\Program Files\jamovi 1.0.7.0\bin\jamovi.exe
> options(jamovi_home="C:\\Program Files\\jamovi 1.0.7.0")
> jmvtools::create('SuperAwesome')

jamovi compiler

jamovi found at C:\Program Files\jamovi 1.0.7.0\bin\jamovi.exe
writing module meta
wrote: 0000.yaml
> setwd('SuperAwesome')
> jmvtools::addAnalysis(name='ttest', title='Independent Samples T-Test')

jamovi compiler

jamovi found at C:\Program Files\jamovi 1.0.7.0\bin\jamovi.exe
wrote: ttest.h.R
wrote: ttest.b.R
wrote: ttest.u.yaml
wrote: ttest.src.js
writing module meta
wrote: 0000.yaml

> jmvtools::install(home="C:\\Program Files\\jamovi 1.0.7.0")

jamovi compiler

jamovi found at C:\Program Files\jamovi 1.0.7.0\bin\jamovi.exe
wrote: ttest.h.R
wrote: ttest.u.yaml
wrote: ttest.src.js
wrote: ttest.js
writing module meta
wrote: 0000.yaml
wrote: jamovi.yaml
'C:\PROGRA~1\jamovi' is not recognized as an internal or external command,
operable program or batch file.

Could not build module
dannyy
 
Posts: 2
Joined: Mon Sep 30, 2019 5:57 pm

by jonathon » Tue Oct 08, 2019 4:06 am

hi,

the issue appears to be windows mis-handling the spaces in the path to jamovi ... i'm not sure why it's doing this for you, and not others. i'll look into it. a simple solution for now is just to install jamovi to a path which doesn't have any spaces in it, like:

c:\program files\jamovi

(without the space and the version number, looks like it will work).

cheers

jonathon
User avatar
jonathon
 
Posts: 1059
Joined: Fri Jan 27, 2017 10:04 am


Return to Module development

cron