package dependency problem

Everything related to the development of modules in jamovi

by seol » Tue May 19, 2020 4:36 am

Hi

While I am trying to build *.jmo module, I got the following error message.

이미지 3.png
이미지 3.png (67.97 KiB) Viewed 1198 times

I think package "correlation" is not available for R 3.6.1 and failed to build a module.

so how can I fix that? Thanks in advance.

Cheers

Seol
seol
 
Posts: 37
Joined: Mon Dec 04, 2017 8:40 am

by jonathon » Tue May 19, 2020 7:05 am

oh yup. correlations was released very recently.

if you update to jamovi 1.2.18, we updated the version of R, and it should work.

cheers

jonathon
User avatar
jonathon
 
Posts: 1382
Joined: Fri Jan 27, 2017 10:04 am

by seol » Tue May 19, 2020 8:04 am

Hi Jonathon

Same error message happened again even though I am using jamovi win1.2.18. R(4.0.0), and updated jmvconnect(1.2.18).

In jmvbaseR-master package, I found R 3.6.1-win 64 folder in subdirectory of build folder. Is that might be a problem?


Could you check it for me? Thanks in advance

Cheers

Seol
seol
 
Posts: 37
Joined: Mon Dec 04, 2017 8:40 am

by jonathon » Tue May 19, 2020 11:11 am

what error do you get this time?

with thanks
User avatar
jonathon
 
Posts: 1382
Joined: Fri Jan 27, 2017 10:04 am

by seol » Tue May 19, 2020 11:52 am

the error message is the same as above;

package "correlation" is not available for R 3.6.1 and failed to build a module.

Cheers

Seol
seol
 
Posts: 37
Joined: Mon Dec 04, 2017 8:40 am

by jonathon » Tue May 19, 2020 11:56 am

hmm,

if it's jamovi 1.2.18, then it should be using R3.6.3 ... what version of jmvtools are you using?

with thanks
User avatar
jonathon
 
Posts: 1382
Joined: Fri Jan 27, 2017 10:04 am

by seol » Tue May 19, 2020 9:54 pm

hi
Hi

i'm using jmvtools 1.3.1 to build a module

With thanks

Seol
seol
 
Posts: 37
Joined: Mon Dec 04, 2017 8:40 am

by jonathon » Tue May 19, 2020 11:53 pm

can you try updating to 1.3.2 of jmvtools (and maybe jamovi 1.2.19 too) and try again. the newer jmvtools will confirm the version number.

sorry for the inconvenience.

with thanks
User avatar
jonathon
 
Posts: 1382
Joined: Fri Jan 27, 2017 10:04 am

by seol » Wed May 20, 2020 2:08 am

Hi Jonathon

Oh yup it works well after installing update version. ^^

With thanks

Seol
seol
 
Posts: 37
Joined: Mon Dec 04, 2017 8:40 am


Return to Module development

cron