gamlj: Mixed Model, "The analysis terminated.."

Everything related to the development of modules in jamovi

by rheredia@tamiu.edu » Mon Dec 21, 2020 7:57 pm

Dear Marcello,

I was working on a mixed models analyses, and I had to remove jamovi 1.6.9 and downgraded to 1.2.27 (Solid).

This is the error that I get.. "Mixed Model :This analysis has terminated, likely due to hitting a resource limit."
The model completely stops. And it appears that I get this error when I do the Post hoc tests.

On Friday (DEC 18), I was using 1.6.8 and it was working fine, and Saturday I downloaded the 1.6.9. That is when I came across the issues.

I am including a screenshot. I sent more information to your account.
I didn’t have this issue with 1.2.27 (Solid).


This is the info about my iMAC if that helps:

macOS Big Sur
Version 11.1
iMac (Retina 5K, 27-inch, 2019)
Processor 3.1 GHz 6-Core Intel Core i5
Memory 72 GB 2667 MHz DDR4
Startup Disk La Llorona



As always, thank you for your wonderful work.
Roberto
Attachments
LinearMixed11.jpg
This is a screenshot of the error message.
LinearMixed11.jpg (130.74 KiB) Viewed 944 times
rheredia@tamiu.edu
 
Posts: 28
Joined: Fri Feb 09, 2018 3:41 pm

by jonathon » Tue Dec 22, 2020 4:25 am

you could try running jamovi at the terminal robert, and see if there's any helpful error messages:

/Applications/jamovi.app/Contents/MacOS/jamovi

cheers

jonathon
User avatar
jonathon
 
Posts: 1689
Joined: Fri Jan 27, 2017 10:04 am

by mcfanda@gmail.com » Tue Dec 22, 2020 8:12 am

Which version of GAMLj are you using?
User avatar
mcfanda@gmail.com
 
Posts: 245
Joined: Thu Mar 23, 2017 9:24 pm

by rheredia@tamiu.edu » Tue Dec 22, 2020 2:30 pm

Hello,

The version I’m using is 1.6.9. That’s the one with the issue.

Jonathan, I’ll try to run it through the terminal later today.
rheredia@tamiu.edu
 
Posts: 28
Joined: Fri Feb 09, 2018 3:41 pm

by rheredia@tamiu.edu » Tue Dec 22, 2020 4:51 pm

Dear Jonathon,

I tried the command and I didn't see anything. It opened jamovi. Is there anything else that I should be doing?
Thanks!
rheredia@tamiu.edu
 
Posts: 28
Joined: Fri Feb 09, 2018 3:41 pm

by mcfanda@gmail.com » Tue Dec 22, 2020 4:51 pm

HI Roberto,
I meant the version of GAMLj, you can see it in the library panel. Be sure that it's the latest, because it may be the combination between jamovi version and GAMLj version.
User avatar
mcfanda@gmail.com
 
Posts: 245
Joined: Thu Mar 23, 2017 9:24 pm

by rheredia@tamiu.edu » Tue Dec 22, 2020 5:02 pm

Dear Marcello,

It is 2.2.0. Isn't this one the latest?
rheredia@tamiu.edu
 
Posts: 28
Joined: Fri Feb 09, 2018 3:41 pm

by rheredia@tamiu.edu » Tue Dec 22, 2020 5:19 pm

I ran the analyses again with the post hoc procedure and I get the error..

Then, I ran it again without the post hoc procedure and I don't get the error.

It seems the issue is with the post hoc procedure. Like I said, 1.6.8 was okay.. and the solid one works just fine...
rheredia@tamiu.edu
 
Posts: 28
Joined: Fri Feb 09, 2018 3:41 pm

by mcfanda@gmail.com » Wed Dec 23, 2020 9:28 am

I found the issue. It applies only to interaction posthoc tests, and it is due to emmeans() change in labeling the comparisons from one version to the other (that is why it works well in jamovi solid, which has an older version of emmeans(). It will be solved in the next version. It should be 2.3.0 (many new features in there) and it will be out in a few days.
thanks for reporting the issue
User avatar
mcfanda@gmail.com
 
Posts: 245
Joined: Thu Mar 23, 2017 9:24 pm

by rheredia@tamiu.edu » Thu Dec 24, 2020 3:14 am

That’s the least I can do to help your very good work.
Looking forward to the next upcoming version.

Thank you!!

Roberto
rheredia@tamiu.edu
 
Posts: 28
Joined: Fri Feb 09, 2018 3:41 pm

Next

Return to Module development

cron