jmvtools::check() returns an error

Everything related to the development of modules in jamovi

by pdeli » Fri Mar 12, 2021 4:34 pm

Hello everyone,

Interested in creating a module for Jamovi, I naturally started with https://dev.jamovi.org/tuts0101-getting-started.html

Unfortunately, already the first step (i.e., install.packages('jmvtools', repos=c('https://repo.jamovi.org', 'https://cran.r-project.org'))) is showing what seem to be a few issues. At the beginning of the process I get this:
Code: Select all
Warning in install.packages :
  unable to access index for repository https://repo.jamovi.org/bin/macosx/contrib/4.0:
  cannot open URL 'https://repo.jamovi.org/bin/macosx/contrib/4.0/PACKAGES'


Then the installation of the package seems to be go on until I get the following warning:
Code: Select all
Error in download.file(url, destfile, method, mode = "wb", ...) :
  download from 'https://repo.jamovi.org/src/contrib/node_1.1.tar.gz' failed


The installation proceeds until this error appears:
Code: Select all
Error in library(jmvtools) : there is no package called ‘jmvtools’
Execution halted


Then when I try jmvtools::check() with the path to Jamovi.app between the parentheses, I get the following:
Code: Select all
Error: 'check' is not an exported object from 'namespace:jmvconnect'


I guess the problem comes from my side. Could someone please help to solve it?

----

Material used:
  • macOS Catalina, version 10.15.7 (19H524)
  • Jamovi version 1.6.18.0 and 1.6.14.0
  • RStudio Version 1.4.1103 ("Wax Begonia" (458706c3, 2021-01-06) for macOS)
  • and RStudio Version 1.4.1106 ("Tiger Daylily" (2389bc24, 2021-02-11) for macOS)
  • R version 4.0.3 (2020-10-10) -- "Bunny-Wunnies Freak Out"
  • and R version 4.0.4 (2021-02-15) -- "Lost Library Book"
pdeli
 
Posts: 21
Joined: Thu Mar 19, 2020 3:05 pm

by jonathon » Wed Mar 17, 2021 10:12 am

hi,

this is just a warning, and you don't need to worry about it:

Code: Select all
Warning in install.packages :
  unable to access index for repository https://repo.jamovi.org/bin/macosx/contrib/4.0:
  cannot open URL 'https://repo.jamovi.org/bin/macosx/contrib/4.0/PACKAGES'


this is your problem here:

Code: Select all
Error in download.file(url, destfile, method, mode = "wb", ...) :
  download from 'https://repo.jamovi.org/src/contrib/node_1.1.tar.gz' failed


the download failed (as they sometimes do, that's just the internet). just repeat the

Code: Select all
install.packages('jmvtools', repos=c('https://repo.jamovi.org', 'https://cran.r-project.org')))


step, and you should be in business.

cheers
User avatar
jonathon
 
Posts: 1729
Joined: Fri Jan 27, 2017 10:04 am


Return to Module development