Mixed Models Module

Everything related to the development of modules in jamovi

by mcfanda@gmail.com » Tue Oct 31, 2017 9:14 am

However, I just updated to ubuntu 17.01, with R 3.4.2, updated jamovi 08.1.1-1, and while compiling I get


Code: Select all
> jmvtools::check()

jamovi compiler


TypeError: Cannot read property '1' of null
    at Object.check (/home/marcello/R/x86_64-pc-linux-gnu-library/3.4/jmvtools/node_modules/jamovi-compiler/installer.js:78:33)
    at Object.<anonymous> (/home/marcello/R/x86_64-pc-linux-gnu-library/3.4/jmvtools/node_modules/jamovi-compiler/index.js:67:19)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)
    at run (bootstrap_node.js:394:7)
    at startup (bootstrap_node.js:149:9)

Cannot read property '1' of null

mcfanda@gmail.com
 
Posts: 143
Joined: Thu Mar 23, 2017 9:24 pm

by jonathon » Tue Oct 31, 2017 9:46 pm

are you using the latest jmvtools? (i improved some of the error reporting).
User avatar
jonathon
 
Posts: 895
Joined: Fri Jan 27, 2017 10:04 am

by mcfanda@gmail.com » Tue Oct 31, 2017 9:51 pm

hi
jmvtool 0.8.4 , R 3.4.2,
installed by
#install.packages('jmvtools', repos=c('https://repo.jamovi.org', 'https://cran.r-project.org'))
on
Linux xps 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:35:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
mcfanda@gmail.com
 
Posts: 143
Joined: Thu Mar 23, 2017 9:24 pm

by jonathon » Tue Oct 31, 2017 11:01 pm

yup, my bad. i overhauled our linux build system recently, and introduced this issue.

i've pushed a 0.8.1.1-2 fixing the issue to the PPA, which should be ready in about 15 minutes (the PPA takes a little while to build it).
User avatar
jonathon
 
Posts: 895
Joined: Fri Jan 27, 2017 10:04 am

by mcfanda@gmail.com » Wed Nov 01, 2017 1:59 am

no joy here. Updated and re-installed. jmvtools::install() hangs with no feedback.
mcfanda@gmail.com
 
Posts: 143
Joined: Thu Mar 23, 2017 9:24 pm

by jonathon » Wed Nov 01, 2017 2:06 am

ah! there's a bug in electron 1.7.8, i'll update that.

incidentally, i'm a little puzzled by the time of day that you post. are you an insomniac? or are you in a different timezone to what i expect you to be in? :)

jonathon
User avatar
jonathon
 
Posts: 895
Joined: Fri Jan 27, 2017 10:04 am

by jonathon » Wed Nov 01, 2017 4:06 am

could you tell me what version of 'jamovitron' is installed on your machine?
User avatar
jonathon
 
Posts: 895
Joined: Fri Jan 27, 2017 10:04 am

by mcfanda@gmail.com » Wed Nov 01, 2017 10:09 am

jamovitron 1.7.8-2

(I'm in amsterdam/rome TZ, but I have a random sleeping pattern, sort of)
mcfanda@gmail.com
 
Posts: 143
Joined: Thu Mar 23, 2017 9:24 pm

by jonathon » Wed Nov 01, 2017 11:47 pm

hmm, i really don't know what this is :/

i'm running artful here and it all works fine :/

what does running `jamovi --version` output?
User avatar
jonathon
 
Posts: 895
Joined: Fri Jan 27, 2017 10:04 am

by jonathon » Thu Nov 02, 2017 1:39 am

can you also double check that jmvtools::check() and install() are finding the correct jamovi version (perhaps there's an old version it's finding?)
User avatar
jonathon
 
Posts: 895
Joined: Fri Jan 27, 2017 10:04 am

PreviousNext

Return to Module development