Rj Editor (Error using System R)

Everything related to the development of modules in jamovi

by Vit » Tue Apr 23, 2019 6:09 am

jmvcore is 0.9.6.4 installed via RStudio. Even after a fresh install no change.
Vit
 
Posts: 7
Joined: Fri Apr 19, 2019 11:51 am

by SvenHeimbuch » Thu Jul 18, 2019 7:34 am

I'm also having issues in using System R with Rj Editor. I'm have jamovi 1.0.4 flatpak (Arch Linux) and R 3.6.1 running on my machine.

When I try to switch from jamovi R to System R, I'm getting this:
Code: Select all
R

To use the system R from jamovi, jmvconnect must be installed

Debug

Error: To use the system R from jamovi, jmvconnect must be installed

private$.run()
stop(message, call. = FALSE)

jmvconnect 1.0.8 is installed (and reinstalled multiple times...) and this is what I get when I try to access spreadsheet data from RStudio when I have a running jamovi instance open:
Code: Select all
library(jmvconnect)
> read()
Error in if (is_http) { : argument is of length zero
> what()
Error in if (is_http) { : argument is of length zero

Any ideas? Any more input required to debug?
User avatar
SvenHeimbuch
 
Posts: 5
Joined: Fri Dec 14, 2018 12:37 pm

by jonathon » Thu Jul 18, 2019 8:32 am

hi sven,

hmm, looks like an error in the httr package ... but no idea why. however, there are complications with using the system R with Rj under linux, due to the sandboxing. but you should still be able to achieve what you want. take a look here:

viewtopic.php?f=6&t=698&p=2466#p2466

come back to us if you get stuck

cheers

jonathon
User avatar
jonathon
 
Posts: 894
Joined: Fri Jan 27, 2017 10:04 am

by shabde » Thu Aug 29, 2019 8:01 pm

Hi Jonathon,

first congrats for a great development as JAMOVI!

I am writing because I have an issue running the RJeditor / jmvconnect under R 3.6.0 in Windows 10. I am using Jamovi 1.1.2.0, but the error is also present with earlier versions. When I try to use the system R in RJ Editor, I get the following error:

Error in readRDS(file = outputPath): cannot read workspace version 3 written by R 3.6.0; need R 3.5.0 or newer
private$.run()
readRDS(file = outputPath)


In RStudio, I can successfully do library (jmvconnect), but when I type what(), I get:

Error in if (is_http) { : argument is of length zero


I still have R 3.5.2 on my system, and have tried to force Jamovi to use it by changing the registry key, but then jmvconnect was not found (albeit installed).

Can you help me out?

Cheers,
Steffen
shabde
 
Posts: 5
Joined: Thu Aug 29, 2019 7:53 pm

by jonathon » Thu Aug 29, 2019 11:43 pm

hi,

so between major versions of R, the libraries are kept separate, so if you've installed `jmvconnect` for 3.6, you'll need to reinstall it for 3.5.

what version of `httr` are you using?

if you've got some time to try some things for me, i'd like to try and get to the bottom of the is_http issue, which seems httr related.

with thanks

jonathon
User avatar
jonathon
 
Posts: 894
Joined: Fri Jan 27, 2017 10:04 am

by shabde » Fri Aug 30, 2019 10:53 am

Thanks Jonathon!

Your hint was right. I had a win environmental variable still pointing to the 3.6 user library, that seemed to be the problem. When only the 3.5 installation of jmvconnect was accessible, Rj editor worked again.

Coming to the other topic:
I am using httr 1.4.1 in R 3.5 and R 3.6. I am getting the is_http error in both environments when I type what().
Sure I can try something, that's the least for such a great development!

Cheers,
Steffen
shabde
 
Posts: 5
Joined: Thu Aug 29, 2019 7:53 pm

by jonathon » Sun Sep 01, 2019 4:40 am

OK, it looks like there's been a regression in the httr package. i've pushed a new version of jmvconnect to CRAN (1.0.9) which works around the issue, and should show up in the next little while.

thanks for alerting us to this

with thanks

jonathon
User avatar
jonathon
 
Posts: 894
Joined: Fri Jan 27, 2017 10:04 am

by shabde » Thu Sep 05, 2019 9:25 am

works perfect now! Thanks a lot for the update!
shabde
 
Posts: 5
Joined: Thu Aug 29, 2019 7:53 pm

Previous

Return to Module development

cron