Unable to compile ...

Everything related to the development of modules in jamovi

by MAgojam » Tue Sep 25, 2018 12:13 pm

Hi, @jonathon.

win 7 Pro (ITA); jamovi 0.9.4.2; jmvtools 0.9.4.1

From RStudio 1.1.456, I launch the compilation of the GAMLj module of @mcfanda and read the following:
Code: Select all
setwd ("d:/jamovi/GitHub_Modules/gamlj-master")
jmvtools::install()
jamovi compiler
found at d:\jamovi-0.9.4.2-win64\bin\jamovi.exe

Unable to compile 'gamljglm.a.yaml':
needs to be upgraded to a higher level


The same msg also acon other modules, what am I missing?
Thanks for your help.

Cheers,
Maurizio
User avatar
MAgojam
 
Posts: 61
Joined: Thu Jun 08, 2017 2:33 pm
Location: Parma (Italy)

by jonathon » Tue Sep 25, 2018 10:15 pm

Hi mz,

I think you've got an old version of gamlj

Jonathon
User avatar
jonathon
 
Posts: 929
Joined: Fri Jan 27, 2017 10:04 am

by MAgojam » Wed Sep 26, 2018 9:26 am

Hi @jonathon,
thanks for the speed with which you answer.
jonathon wrote:I think you've got an old version of gamlj

The version of GAMLj was 1.0.0, recently released by @mcfanda.

I think the msg is due to a malfunctioning of the PC that like other Lenovo (in the same day) ended with a series of spontaneous reboots and unlocked with an "Error Code 1962" with HD dead.
Replaced HD recovered backups, compiling did not give problems.

Cheers,
Maurizio
User avatar
MAgojam
 
Posts: 61
Joined: Thu Jun 08, 2017 2:33 pm
Location: Parma (Italy)

by jonathon » Wed Sep 26, 2018 10:11 pm

great!
User avatar
jonathon
 
Posts: 929
Joined: Fri Jan 27, 2017 10:04 am


Return to Module development

cron