stan packages erro

Everything related to the development of modules in jamovi

by Jinghaom » Tue Nov 13, 2018 1:23 pm

hi

I tried to delete the entire module file and reinstalled R and Rstudio. Now that it works, I get the results I want.
thank you very much.

By the way
The jamov I used is the zip version and put it in it.
C:\jamovi-0.9.5.8-win64
At this point stan can run normally

If i download the exe version and install it, the directory is
C:\Program Files\jamovi 0.9.5.6
And run stan with this jamovi, I get the following error.
Code: Select all
Error in sink(type = "output"): invalid connection private$.run()
stan_model(model_code = mode)
cxxfunctionplus(signature(), body = paste(" return Rcpp::wrap(\"", model_name, "\");", sep = ""), includes = inc, plugin = "rstan", save_dso = sav
sink(type = "output"


I think this may be because r can't recognize the space between "Program" and "Files" in "C:\Program Files\",I have encountered this error. So I switched to the zip version and put it in
C:\jamovi-0.9.5.8-win64
solved this problem.

Anyway, stan can now work properly. I can continue my development.
Pay tribute to you
Jinghaom
 
Posts: 13
Joined: Mon Nov 05, 2018 1:05 pm

by jonathon » Tue Nov 13, 2018 10:17 pm

yup, i found the C:\Program issue while looking at your module too :)

i'll look into it in the next little while.

with thanks
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by jonathon » Mon Nov 19, 2018 9:50 am

the 0.9.5.9 is out now, and you won't need to do the Sys.setenv() trick any more.

are you having the "C:\Program" issue still? i think it might be fixed with the latest version of stan.

cheers

jonathon
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by Jinghaom » Sat Nov 24, 2018 1:26 pm

Sorry, I replied late.

It is true that 0.9.5.9 does not require Sys.setenv().
Thank you

But when I installed it with the exe version in
"C:\Program Files\jamovi 0.9.5.9"

The following error occurred
Code: Select all
Debug
Error in sink(type = "output"): invalid connection

private$.run()
stan_model(model_code = mode)
cxxfunctionplus(signature(), body = paste(" return Rcpp::wrap(\"", model_name, "\");", sep = ""), includes = inc, plugin = "rstan", save_dso = sav
sink(type = "output")


I removed the build file to re-download the rstan package, so I think my version is the latest stan.

with thanks

Jinghao
Jinghaom
 
Posts: 13
Joined: Mon Nov 05, 2018 1:05 pm

Previous

Return to Module development

cron