[SOLVED] one-way ANOVA error

General help and assistance with jamovi. Bug reports can be made at our issues page: https://github.com/jamovi/jamovi/issues . (If you're unsure feel free to discuss it here)

by bradg » Wed Nov 15, 2017 12:11 am

Thanks for taking the time to help!

the code I am using is: dat <- read.csv("PSY.308b.DA2.csv") the issue is the same for all files i have tried
I am on a 2017 macbook pro, running macOS Sierra, version10.12.6.
For R studio I am using version Version 1.1.383

Thanks again,
Brad
bradg
 
Posts: 6
Joined: Fri Nov 10, 2017 7:25 pm

by jonathon » Wed Nov 15, 2017 12:14 am

could you attach the data file, and provide the anova command you are using too?

with thanks
User avatar
jonathon
 
Posts: 1483
Joined: Fri Jan 27, 2017 10:04 am

by bradg » Wed Nov 15, 2017 12:32 am

Sure,
jmv::anova(data = dat, dep = 'HELPING', factors = c('HASTE'), effectSize = 'partEta', postHoc = c('HASTE'), postHocCorr = 'tukey', homo = TRUE)
Attachments
PSY.308b.DA2.csv
(415 Bytes) Downloaded 396 times
bradg
 
Posts: 6
Joined: Fri Nov 10, 2017 7:25 pm

by jonathon » Wed Nov 15, 2017 12:36 am

hmm, what does excuting in R:

R.version

output?

with thanks
User avatar
jonathon
 
Posts: 1483
Joined: Fri Jan 27, 2017 10:04 am

by bradg » Wed Nov 15, 2017 1:29 am

platform x86_64-apple-darwin15.6.0
arch x86_64
os darwin15.6.0
system x86_64, darwin15.6.0
status
major 3
minor 4.2
year 2017
month 09
day 28
svn rev 73368
language R
version.string R version 3.4.2 (2017-09-28)
nickname Short Summer
bradg
 
Posts: 6
Joined: Fri Nov 10, 2017 7:25 pm

by bradg » Wed Nov 15, 2017 11:10 pm

Jonathan,
My professor was able to finally find a solution.

as.factor(dat$HASTE)

was used although, class(dat$HASTE) gave us the output
[1] "integer"

We then used dat$HASTE<-as.factor(dat$HASTE), which successfully defined HASTE as a factor
Running the ANOVA then gave us the error

Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
there is no package called ‘quantreg’

Instaling "Quantreg" fixed my issue with ANOVA's and Levene's test, although we have no idea why this package was not installed already.

Thanks for all your help!
bradg
 
Posts: 6
Joined: Fri Nov 10, 2017 7:25 pm

by jonathon » Wed Nov 15, 2017 11:12 pm

awesome brad!

i'll keep working on this, and try to get to the bottom of it, but i'm glad you've got something working.

with thanks
User avatar
jonathon
 
Posts: 1483
Joined: Fri Jan 27, 2017 10:04 am

by Priyanka_S » Tue Nov 10, 2020 6:32 pm

Hello, I am a teaching assistant in this same class 3 years later (but during the coronavirus lockdowns, so not as easily able to get help from people around me) and I'm having this same problem even after trying what was listed in this thread. I hope to be able to troubleshoot with someone on here!
Priyanka_S
 
Posts: 3
Joined: Tue Nov 10, 2020 6:26 pm

by jonathon » Wed Nov 11, 2020 12:40 am

hi, could you start a new thread?

with thanks
User avatar
jonathon
 
Posts: 1483
Joined: Fri Jan 27, 2017 10:04 am

Previous

Return to Help