Rj editor error?

General help and assistance with jamovi. Bug reports can be made at our issues page: https://github.com/jamovi/jamovi/issues . (If you're unsure feel free to discuss it here)

by Hypersphere » Sat Aug 04, 2018 11:08 pm

Using jamovi 0.9.11 for Windows 10 ver 1803, R version 3.5.1.

When I try to open Rj editor, I get the following:
=====
library(jmv)
if (packageVersion('jmv') < package_version('0.9.1.10'))
stop('A newer version of jmv is required')

# descriptives(data[1:3])

=====

In addition, in the R output in the right-hand panel, I get:

R
argument is of zero length

In R, my jmv package version is 0.8.6.2
jmv connect version is 1.0.3
jmvcore version is 0.9.10

Do I need an updated jmv package in R?
User avatar
Hypersphere
 
Posts: 6
Joined: Wed Aug 01, 2018 10:55 pm

by jonathon » Sat Aug 04, 2018 11:10 pm

hi, is this with the 'jamovi R', or with the 'System R'?

with thanks
User avatar
jonathon
 
Posts: 993
Joined: Fri Jan 27, 2017 10:04 am

by MAgojam » Sun Aug 05, 2018 2:27 pm

Hypersphere wrote:In R, my jmv package version is 0.8.6.2
jmv connect version is 1.0.3
jmvcore version is 0.9.10

Do I need an updated jmv package in R?

Hi @Hypersphere,
I'm using Rj with win7 and 10 (latest updates) without problems.

Installed with RStudio or from R terminal, in Sytem Library, the most recent version of jmv present in GitHub ...
Code: Select all
devtools::install_github("jamovi/jmv", force=TRUE)

cheers,
Maurizio
User avatar
MAgojam
 
Posts: 63
Joined: Thu Jun 08, 2017 2:33 pm
Location: Parma (Italy)


Return to Help

cron