Trouble creating plots (plots not loading)

General help and assistance with jamovi. Bug reports can be made at our issues page: . (If you're unsure feel free to discuss it here)

by jules_verne » Tue Aug 21, 2018 10:04 pm

jonathon wrote:ah ok, are you using what might be considered a 'minimal install'?

try this:

with thanks

Hi, Jonathon.
I am not using a minimal install.

Tried. Same thing stills happening.
Posts: 11
Joined: Sun Aug 19, 2018 7:26 pm

by jules_verne » Tue Aug 21, 2018 10:50 pm

Solved adding

export LC_ALL="en_US.UTF-8"

to .profile.
Posts: 11
Joined: Sun Aug 19, 2018 7:26 pm

by jonathon » Tue Aug 21, 2018 11:41 pm

ah! good trouble-shooting!

i'll see if we can add something like this to the flatpak.

cheers and thanks for your help

User avatar
Posts: 1382
Joined: Fri Jan 27, 2017 10:04 am

by zorzevic » Thu Feb 20, 2020 10:34 am


Same problem here and it indeed gets solved by running
Code: Select all
LC_ALL=C flatpak run org.jamovi.jamovi

so no wonder setting LC_ALL to C in .profile would solve the problem.

However, since it's considered bad practice to do so and it might cause issues running other programs expecting different locales (I'm using fr locales for most programs), I'd just like to know if any other solution came up lately?

Of course I could just run Jamovi through the terminal every time but I feel like this issue might be limiting the popularity of this amazing piece of software among non-english locale users (definitely the case for some of my students for instance)...

Posts: 1
Joined: Thu Feb 20, 2020 10:22 am


Return to Help