Saving analysis error (0.9.6.7)

General help and assistance with jamovi. Bug reports can be made at our issues page: https://github.com/jamovi/jamovi/issues . (If you're unsure feel free to discuss it here)

by MAgojam » Mon Apr 15, 2019 11:31 am

Hi, Jonathon.
I'm trying jamovi 0.9.6.7 and wanted to tell you, that saving an analysis or table, both in pdf and html, fails with the message:
Save failed
TypeError: options.exclude is not a function

There are no problems if I use Export from backstage.

Still with the last release, I worked on an omv file provided by a colleague.
Now, the colleague, who uses 0.9.6.6, fails to load it with the message:
Unable to open filename.omv
A newer version of jamovi the required

This is not a problem, but is it possible that this latest version has undergone such a big change?

Thank you very much, as always, for your attention.
Cheers.
Maurizio
User avatar
MAgojam
 
Posts: 46
Joined: Thu Jun 08, 2017 2:33 pm
Location: Parma (Italy)

by jonathon » Tue Apr 16, 2019 1:39 am

hi maurizio,

good catch. i'm pushing out a 0.9.6.9 which will fix the save issue.

re: 'A newer version of jamovi is required', it's true there weren't big changes between 0.9.6.6 and .7, but there have been a number of changes between 0.9.5.x. the more changes we introduce, the more likely someone will try and open a file in an earlier version, where that feature is missing. so we do need to introduce a file version bump from time to time.

so i agree, it does feel silly when you compare it to the immediately preceding version, but we have to introduce the bump somewhere. in this case, we've introduced it when the 0.9.6 series has become 'solid'. i.e. when we're happy for everyone to upgrade to the 0.9.6 series.

cheers

jonathon
User avatar
jonathon
 
Posts: 837
Joined: Fri Jan 27, 2017 10:04 am

by MAgojam » Tue Apr 16, 2019 10:29 am

Hi Jonathon,
I confirm solution of the problem with v. 0.9.6.9.

Thanks and best regards.
Maurizio
User avatar
MAgojam
 
Posts: 46
Joined: Thu Jun 08, 2017 2:33 pm
Location: Parma (Italy)

by Nico » Mon May 27, 2019 4:54 pm

Hi Jonathon,

I have downloaded the latest version for windows and I can't save my file. For some reason, the system cannot find the path specified.

Thank you

Nico
Nico
 
Posts: 2
Joined: Tue Apr 30, 2019 10:42 am

by jonathon » Mon May 27, 2019 10:17 pm

hi,

is this a one-off occurrence, or does this happen with every file you try and save?
if you select 'save-as', and choose a different location, does it fix the issue?

i could see this error occurring if you saved the file to a location, then renamed one of the directories it was in, before resaving.

jonathon
User avatar
jonathon
 
Posts: 837
Joined: Fri Jan 27, 2017 10:04 am

by Nico » Wed May 29, 2019 9:45 pm

Hi Jonathon, thank you for the reply, we spoke on Twitter and it's now sorted. I lost the file but it hasn't happened again. Thank you again for the support

Nico
Nico
 
Posts: 2
Joined: Tue Apr 30, 2019 10:42 am


Return to Help

cron