plot font problems

General help and assistance with jamovi. Bug reports can be made at our issues page: https://github.com/jamovi/jamovi/issues . (If you're unsure feel free to discuss it here)

by marco » Wed Aug 28, 2019 10:38 pm

Hi!

I run jamovi (1.1.2.0) on a ubuntu machine (19.04). The analysis works well and I think it is a fantastic software.

But I have a problem with the plots.

In the graph seems disappear the font for the didascalic information.

Can you help me?

Marco
Attachments
Screenshot from 2019-08-29 00-33-03.png
Screenshot from 2019-08-29 00-33-03.png (32.1 KiB) Viewed 2023 times
marco
 
Posts: 5
Joined: Wed Aug 28, 2019 10:19 pm

by jonathon » Thu Aug 29, 2019 12:21 am

hi marco,

yes, there is something peculiar with plot fonts on some linux machines. i'm discussing this with the flatpak people.

if you run jamovi at the terminal (flatpak run org.jamovi.jamovi) are there any error messages?

with thanks
User avatar
jonathon
 
Posts: 1263
Joined: Fri Jan 27, 2017 10:04 am

by marco » Thu Aug 29, 2019 9:02 am

Hi Jonathon,

thanks for your immediate response.

I received this error: Failed to load module "canberra-gtk-module". Is it inherent?

Thanks
marco
 
Posts: 5
Joined: Wed Aug 28, 2019 10:19 pm

by marco » Thu Aug 29, 2019 9:11 am

I tried to install canberra module for 32 bit (since I already have the module for 64 bi) but nothing changed. IN the terminal received he same error
marco
 
Posts: 5
Joined: Wed Aug 28, 2019 10:19 pm

by marco » Thu Aug 29, 2019 9:13 am

But i don't think canberra has a relation with my problem

https://wiki.archlinux.org/index.php/Libcanberra
marco
 
Posts: 5
Joined: Wed Aug 28, 2019 10:19 pm

by marco » Tue Sep 17, 2019 2:10 pm

Hi Jonathon,

Is it possible to know if this annoying problem can be solved?
marco
 
Posts: 5
Joined: Wed Aug 28, 2019 10:19 pm

by jonathon » Wed Sep 18, 2019 3:20 am

hi,

it's quite a tricky problem to solve. the situation as i understand it, is:

so jamovi on linux runs inside a flatpak
to perform plots, jamovi uses R
R uses the font settings provided by the flatpak runtime
for a small proportion of users, there's some sort of mismatch between the font settings provided by the flatpak, and what's actually available

so it's the sort of issue that if you approached the R people about, they'd say, go and talk to the font-config people, the font-config people would say to go and talk to the flatpak people, and the flatpak people would say go and talk to the R people.

raising the level of complexity are two additional things: 1. i can't reproduce it on any machine i have access to 2. i know nothing about font-config :/

so at the moment i'm not feeling optimistic.

sooner or later we'll get our ducks in a row, but it's the sort of issue where you have to wait for some sort of breakthrough somewhere.

if it's any consolation, i'm atleast as frustrated as you are.

cheers

jonathon
User avatar
jonathon
 
Posts: 1263
Joined: Fri Jan 27, 2017 10:04 am

by jonathon » Thu Oct 17, 2019 11:47 pm

could you try this command, and see if it fixes the issue:

flatpak run --command=fc-cache org.jamovi.jamovi -f -v

with thanks
User avatar
jonathon
 
Posts: 1263
Joined: Fri Jan 27, 2017 10:04 am

by xvila » Mon Nov 11, 2019 9:54 pm

jonathon wrote:could you try this command, and see if it fixes the issue:

flatpak run --command=fc-cache org.jamovi.jamovi -f -v

with thanks


Yes, it does !
Thank you !
xvila
 
Posts: 1
Joined: Mon Nov 11, 2019 9:52 pm

by laurent.sediens » Sat May 09, 2020 9:52 am

Hi!
My computer works under Ubuntu 18.04. I experience the same problem as reported by Marco, but the command line Jonathon suggested did not solve the problem for me.
Is there something else I could try to solve the issue ?
Thanks !

Capture du 2020-05-09 11-45-13.png
Capture du 2020-05-09 11-45-13.png (33.83 KiB) Viewed 286 times
laurent.sediens
 
Posts: 1
Joined: Sat May 09, 2020 9:40 am

Next

Return to Help