clinicopath, survival analysis

Everything related to the development of modules in jamovi

by rabouqal » Mon Sep 21, 2020 11:07 am

Hello,
Thank you for the very useful clinicopath module in medical research.
In the survival analysis, the unit is the month. For acute illnesses (Covid-19 for example), the unit can be during the day. Is it possible to choose the unit of time (month or day) in the module. I tried, but it is fixed on the month.

Thank you.
rabouqal
 
Posts: 6
Joined: Thu Mar 22, 2018 6:11 pm

by sbalci » Mon Sep 21, 2020 11:59 am

Hi,
Please update to jamovi 1.6.3 and to the latest version of jsurvival. And use advanced elapsed time options. There you can select time type in output.
sbalci
 
Posts: 61
Joined: Sat Jan 06, 2018 10:25 pm

by rabouqal » Mon Sep 21, 2020 12:20 pm

Thank you for your answer
rabouqal
 
Posts: 6
Joined: Thu Mar 22, 2018 6:11 pm

by happyhuni » Wed Apr 14, 2021 3:57 am

Hi. sbalci

Thank you very much for developing the jsurvival-Survival Module of clinical path for jamovi module.

When I writing a manuscript, this module support HR or OR with 2 decimal places.

Can you support HR or OR with 3 decimal places to match P value?

Thank you.
happyhuni
 
Posts: 1
Joined: Wed Apr 14, 2021 3:50 am

by sbalci » Thu Apr 15, 2021 6:32 am

Hi, I am glad you found the module useful.
I have to check the packages I use to see if decimals could be adjusted. However I do not think that more than 2 decimals would be necessary. A death risk 2.345 times does not seem to give more information to the reader than 2.35 times.
I also do not think that you have to use the same decimal numbers for a p-value and HR. They are completely different calculations and do not need to be compared to interpret the results.
sbalci
 
Posts: 61
Joined: Sat Jan 06, 2018 10:25 pm

by drmikemozer » Mon Apr 26, 2021 7:56 pm

Sorry. I must be getting old. I cannot figure out how to post a new question. So here is my question: which version of Jamovi is the right one to install the clinicopath module? I tried with Jamovi 1.6.23.0 and got the message "INSTALLED VERSION IS INCOMPATIBLE". So I uninstalled and then installed 1.8.1 thinking this newer version might be the one it is compatible with. Same error message appeared... I presume Clinicopath is compatible with an older version, but how do I get a hold of an older version. Any help would be appreciated.
drmikemozer
 
Posts: 1
Joined: Mon Apr 26, 2021 7:28 pm

by sbalci » Mon Apr 26, 2021 8:41 pm

Hi, It should be compatible with 1.8 series. Would you please share a screenshot?
sbalci
 
Posts: 61
Joined: Sat Jan 06, 2018 10:25 pm

by jonathon » Tue Apr 27, 2021 12:21 am

if you browse the jamovi library you'll find the option to update to a compatible version of clinicopath irrespective of what version of jamovi you are using.

cheers

jonathon
User avatar
jonathon
 
Posts: 1721
Joined: Fri Jan 27, 2017 10:04 am


Return to Module development