QQ-Plot Repeated Measures ANOVA

Discuss statistics related things

by Lea » Tue May 11, 2021 7:29 am

Hi Jamovi Team,
my student uses Jamovi for her thesis and she reported a strange QQ-Plot for a repeated measures ANOVA: Image. (https://ibb.co/tDxpx4H)
It seems to me that somehow the dots are the unstandardized residuals, but the line is based on the standardized ones. If I just looked at the QQ-Plots from the two separate variables (via Descriptives), the lines actually go through the dots, so the variables look fine to me.

I checked the QQ-Plots in R (fitting a mixed model), using performance::model_check(). Here the line actually matches the dots:
Image (https://ibb.co/bRP2KL7)

Finally, I made a QQ-Plot with the unstandardized residuals and the lines for both the standardized and unstandardized residuals, and you can see that the combination of unstandardized dots and standardized line matches Jamovi's QQ-Plot:
Image (https://ibb.co/wJPw6Vc)

So could it be that there is an error in the QQ-Plot code? Or am I missing something?

(The first QQ-Plot is from a "reduced" rm Anova with only one 2-level factor as predictor to replicate the problem. These are actually count data, but my student wanted to know whether they are "normal" enough to analyze with an Anova for her thesis. I also don't think that this is relevant for the problem, but who knows.)
Lea
 
Posts: 1
Joined: Mon May 10, 2021 2:13 pm

by rjeronimoss » Fri Aug 13, 2021 3:43 am

Hello Lea!

I have the same doubt as you!
I also identified this behavior in QQPlot for repeated measures ANOVA, and I would like an answer.
Did you get any response from the JAMOVI Team?

Regards

Jeronimo
rjeronimoss
 
Posts: 1
Joined: Fri Aug 13, 2021 3:31 am

by Ravi » Tue Aug 17, 2021 9:48 am

Hi Lea and Jeronimo,

Sorry for not getting back to you earlier Lea, sometimes forum questions slip through the cracks. But you are absolutely right, the QQ plot uses unstandardized residuals, instead of standardized residuals. I fixed the bug (see, https://github.com/jamovi/jmv/pull/315) and this fix will be added to the next version of jamovi.

Thanks for reporting the issue!

Cheers,
Ravi
User avatar
Ravi
 
Posts: 177
Joined: Sat Jan 28, 2017 11:18 am


Return to Statistics