Problems trying to use the igraph package

Everything related to the development of modules in jamovi

by jonathon » Fri Dec 14, 2018 10:01 pm

oh yup.

i'll update the Rcpp we ship to with the macOS version to 1.0

with some of the server stuff i'm working on at the moment, i may get to solving this issue once and for all.

cheers
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by Fhas » Sat Jan 05, 2019 10:20 am

solving this issue once and for all


That would be great!!

Meanwhile...

Screenshot 2019-01-05 at 11.15.34.png
Screenshot 2019-01-05 at 11.15.34.png (47.45 KiB) Viewed 647 times
Fhas
 
Posts: 27
Joined: Wed Sep 12, 2018 2:55 pm

by jonathon » Sat Jan 05, 2019 10:48 am

oh yup. next macos version will ship with tibble 2.0

jonathon
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by jonathon » Mon Jan 21, 2019 4:16 am

(0.9.5.16 is out, in case you missed it).
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by Fhas » Sun Jul 07, 2019 11:47 pm

Hi!

Wow, great progress, and congrats on version 1!

I haven't engaged with JAMOVI for a while and wanted to rebuild my module....
I noticed I had to remove the "inputPattern" field, no problem.
Now I am getting an error I have never encountered before:

ERROR: dependencies ‘tseries’, ‘quadprog’, ‘sapa’, ‘fractal’, ‘ifultools’, ‘wmtsa’, ‘igraph’ are not available for package ‘casnetjmv’
* removing ...


So, these packages are installed on my machine under R 3.6 without any problems. I tried to remove packages from 'Imports', because some I really do not need, but apparently they are dependencies of other packages I really do need...

Any ideas on what might be going on?

(the module is at: https://github.com/FredHasselman/casnet-jmvMAC)
Fhas
 
Posts: 27
Joined: Wed Sep 12, 2018 2:55 pm

by jonathon » Mon Jul 08, 2019 12:25 am

hi fred,

i've been wondering where you were!

try deleting (or renaming) the build folder, and let it pull down a fresh set of dependencies.

cheers

jonathon
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by Fhas » Mon Jul 08, 2019 2:26 am

Oh, I missed you guys too! :grinning:

Deleting the build folder does not help me...

1: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘quadprog’ had non-zero exit status
2: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘ifultools’ had non-zero exit status
3: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘igraph’ had non-zero exit status
4: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘sapa’ had non-zero exit status
5: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘wmtsa’ had non-zero exit status
6: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘fractal’ had non-zero exit status
7: In utils::install.packages(c("tseries", "tidyr", "quadprog", "zoo", :
installation of package ‘tseries’ had non-zero exit status
ERROR: dependencies ‘tseries’, ‘quadprog’, ‘sapa’, ‘fractal’, ‘ifultools’, ‘wmtsa’, ‘igraph’ are not available for package ‘casnetjmv’
* removing ...

Could not build module
Fhas
 
Posts: 27
Joined: Wed Sep 12, 2018 2:55 pm

by jonathon » Mon Jul 08, 2019 3:33 am

hey, yeah,

debugging why R packages won't install on a particular computer is a bit of a nightmare.

i've downloaded your module, built it, and here's a build folder you can use:

build.zip
(17.48 MiB) Downloaded 11 times


cheers

jonathon
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

by Fhas » Mon Jul 08, 2019 11:13 am

that's brilliant! Thanks a lot, I just built it.

So far, there's just this rlang issue again:

Screenshot 2019-07-08 at 13.05.46.png
Screenshot 2019-07-08 at 13.05.46.png (16.32 KiB) Viewed 91 times
Fhas
 
Posts: 27
Joined: Wed Sep 12, 2018 2:55 pm

by jonathon » Tue Jul 09, 2019 12:58 am

woops.

i've just done a 'silent update' to the 1.0.4, so if you download and install that again, you'll get the latest rlang.

cheers

jonathon
User avatar
jonathon
 
Posts: 841
Joined: Fri Jan 27, 2017 10:04 am

Previous

Return to Module development